ATI Radeon 9800 Patch
for Mac

OSX10.3.3 graphics card fix.

  • Total Downloads
  • Downloads Last Week
  • User Rating
  • My Rating

ATI Radeon 9800 Patch Description

Software Requirements

* Mac OS X version 10.2.8 (Jaguar) or higher (10.3.X or higher recommended, 10.4.X required for VERSAVISION with OEM graphics)
* Power Macintosh Desktop Computer
* 128MB of system memory - (512MB recommended)
* August 2005 ATI Radeon Universal ROM Update or higher for full advanced feature-set on retail board products

ATI Radeon 9800 Patch Screenshots

Screenshots are not available currently.

What's New in ATI Radeon 9800 Patch 4.5.7

Release notes are not available currently.

ATI Radeon 9800 Patch Requirements

Operating Systems:

Mac OS X

System Requirements:

No additional system requirements.

Quick Specifications

See Full Specifications

More From Advanced Micro Devices, Inc.

See More

Essential Downloads in Audio & Video

See More